Home Forums .NET libraries Xceed SFTP/FTP for .NET Xceed .FTP timeout GetFolderContents

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • wimdevriendt
    Participant
    Post count: 1
    #44424 |

    I get a timeoutexception when I do GetFolderContents
    however when filezilla connects to the site it’s succeeding but it is using a workaround

    Binding data connection source IP to control connection source IP 172.30.30.55

    14:14:09 Command: PASV
    14:14:09 Response: 227 Entering Passive Mode (192,168,11,250,192,17).
    14:14:09 Status: Server sent passive reply with unroutable address. Using server address instead.
    14:14:09 Trace: Reply: 192.168.11.250, peer: 213.119.36.234
    14:14:09 Trace: Binding data connection source IP to control connection source IP 172.30.30.55

    14:14:09 Command: LIST
    14:14:09 Response: 125 Data connection already open; transfer starting.

    Fawzi [Xceed]
    Member
    Post count: 722

    Hi,

    You can set the FtpClient.UseRemoteAddress property to true. This will make the client use the control connection’s address like FileZilla does.

    Documentation: https://xceed.com/wp-content/documentation/xceed-filesystem-for-net/webframe.html#topic2145.html

    Unfortunately, the behavior cannot currently be made automatic. You have to set the property manually for the servers you think will need it before you attempt a data connection.

    We will look into adding an option to use the remote address automatically if the address returned by the PASV command is unroutable in the next 2 weeks.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.