Home Forums WPF controls Other WPF controls Avalondock: MVVM can't show hidden LayoutAnchorable after Deserialization

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Masc
    Participant
    Post count: 2
    #48146 |

    Hello,

    I encountered a bug, that hidden LayoutAnchorables cannot be shown when loaded from an XML (Deserialization).

    The problem is a little bit hard to describe, but i try my best.

    The first problem (bug) i had, was when i added LayoutAnchorables to my ViewModel. They appeared as intended but there was a blank space on the left. I managed to build a workaround:
    – there was an empty LayoutDocumentPaneGroup created by the DockingManager (is that intended to happen?)
    – if i remove this LayoutDocumentpaneGroup everything works just fine

    The 2nd problem needs a little bit more explanation:
    – In my Test-Application i add 3 LayoutAnchorables, they are organized in Tabs:
    | 3 | ( || are the borders and 3 means 3 tabs)
    – after that i do the following steps:
    1. | 2 | 1 | (move one LayoutAnchorable to the right)
    2.
    | 1 | 1 |
    ---------
    | 1 | (move one LayoutAnchorable to the bottom)
    3. Close the application (it gets serialized)
    4. Open the application (it gets deserialized, the layout gets loaded)
    5. Hide the upper 2 LayoutAnchorables => that leaves a blank space (why?)

    ---------
    | 1 |
    6. Close the application and reopen it
    7. The Layout that gets loaded is:
    | 1 | (no blank space)
    8. I try to make the other LayoutAnchorables appear by setting the bound Property IsVisible to true => they dont appear

    I could recreate this behavior in a small Test-Application, where i removed every unnecessary part. I could also send you a little video of the bug, because its hard to describe.

    Thank you in advance.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.