Home Forums WinForms controls Other WinForms controls Flickering Problem with docking windows

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • User (Old forums)
    Member
    Post count: 23064
    #18524 |

    I m using visual Sudio 2008. I m using docking windows in project. the problem arises when i click the auto hide button the flickering occurs. i dont know why this flickering occuring. Can any body help me out . Thanks in advance.

                                                                                                                          Rashid Khan

                                                                                                                                 

    Imported from legacy forums. Posted by Rashid (had 5184 views)

    User (Old forums)
    Member
    Post count: 23064

    Can you provide more details?  What’s on the ToolWindow?  How do you set up the application?  How many ToolWindows is there in the application?  Etc…

     

    Imported from legacy forums. Posted by André (had 2580 views)

    User (Old forums)
    Member
    Post count: 23064

    sir,

         I have panel named pnlBar. and i have different button and check boxes on it. i m creating tool windows of it and displaying in my form as docking window. The code i m using is

     

    Dim  bar_Object As ToolWindow

    bar_Object =

    New ToolWindow(pnlBar, “BarObject”)

    With bar_Object

    .State = ToolWindowState.AutoHide

    .Key =

    “BarObject”

    .Text =

    “Bar Series Properties”

    .AutoSize =

    False

    .Size =

    New System.Drawing.Size(4, 4)

    End With

    pnlBar.Dock = DockStyle.Fill

    With DockLayoutMain

    .SuspendLayout()

    .ToolWindows.Add(bar_Object)

    .AllowFloating =

    True

    end with

    bar_Object.DockTo(DockTargetHost.ClientHost, DockPosition.Bottom)

     

    Sir i have four tool windows on main form. i have group three of them and displaying in tab

     

    DockLayoutMain.ToolWindows(

    “BarObject”).DockTo(DockLayoutMain.ToolWindows(“LineObject”), DockPosition.Group)

    DockLayoutMain.ToolWindows(

    “PrintObject”).DockTo(DockLayoutMain.ToolWindows(“LineObject”), DockPosition.Group)

    DockLayoutMain.ToolWindows(

    “PieObject”).DockTo(DockLayoutMain.ToolWindows(“LineObject”), DockPosition.Group)

    DockLayoutMain.ToolWindows(

    “LineObject”).ParentGroup.DockTo(DockTargetHost.ClientHost, DockPosition.Right)

     

    The problem is with auto hiding button . when i click on that button to auto hide the window the flickering occurs.

    i will be looking for your kind response.

                                                                   Thanks

                                                                        Rashid Khan

                                                                              Software developer

     

    Imported from legacy forums. Posted by Rashid (had 464 views)

    User (Old forums)
    Member
    Post count: 23064

    It is difficult to tell the issue just looking at your code, especially that we don’t know what’s on the different ToolWindows (e.g. PieObject, LineObject).  Is it ToolWindows with charts having a heavy loads of data points for example?

    What we can say is that we don’t experience this behavior here.  It would be best if you could send us a sample application reproducing the issue, at support@xceed.com, so we can investigate this further.  Please provide a link to the present post in your email.

     

    Imported from legacy forums. Posted by André (had 2426 views)

    User (Old forums)
    Member
    Post count: 23064

    This is a bug, and we have logged a bug report for it.

    At this time, no time frame has been set to correct the issue, as we need more time to investigate the issue.

    Imported from legacy forums. Posted by André (had 2994 views)

    User (Old forums)
    Member
    Post count: 23064

    I would like to get an update for this issue…i mean to say has this problem been resolved?.

    Imported from legacy forums. Posted by kir (had 615 views)

    User (Old forums)
    Member
    Post count: 23064

    Hi,

    I ran into the same problem as you. It appears that the main form has to be set as a MDI container (IsMdiContainer =  True). This makes the flickering go away. But his way you have a problem when your form is a MDI child (my case 🙁 ) as a form cannot be a MDI child and a MDI parent at the same time.

    Maybe this will help the Xceed team in debugging this.  

     

    Imported from legacy forums. Posted by Razvan (had 2950 views)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.